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NOTICE: THIS DOCUMENT WAS WRITTEN BY A USER USING WINDOWS 7.  THERE WILL BE SOME 
LOCATION AND APPEARANCE DIFFERENCES COMPARED TO WINDOWS XP AND VISTA. 

 

Installing SolidWorks 

Installing SolidWorks (Standalone) 

When attempting to install SolidWorks, you should be logged in as the Administrator on that 
computer. 
 
Before the installation begins, any anti-virus or anti-spyware should be completely disabled using the 
Services menu.  This can be accessed by going to Start-> Run, type “services.msc” (without 
quotations).  Once the Services window has opened select each instance of the anti-virus program and 
stop it. 
 

 
 
* IMPORTANT - If you are running Windows Vista or Windows 7, it is recommended to disable your 
User Account Controls as this can cause conflicts with your SolidWorks installation.  For steps to disable 
this option, browse to http://www.javelin-tech.com/blog/2011/01/uac/ 
 
Once the anti-virus and User Account Controls have been completely disabled, and you are logged in as 
the system administrator, you can begin the SolidWorks installation.  When prompted to enter your 
SolidWorks serial number, enter the full, 24 digit serial number.   
 
Note:  If you have purchased multiple SolidWorks products (such as Simulation, Motion, etc), then you 
must click the blue link “Click here to enter additional serial numbers” to enter the serial number for 
each product that you are trying to install, even if the serial numbers are the same for each product. 
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Continue with the installation.  For further information, click the “Help” button within the SolidWorks 
Installation Manager.  For information on installing multiple releases of SolidWorks in unique 
directories, see the section of this document entitled Installing to a Unique Directory. 
 

Installing SolidNetwork License Manager (SNL) 

Beginning with the SW2010 release, the SNL SolidNetwork License Manager uses activation based 
licensing.  This document will detail installing the licensing server for SW2010 and later.  If you require 
assistance with this for SW2009 (or earlier), please contact Javelin Technical Support for instructions 
specific to this scenario.   
 
When installing SolidWorks with a network license, there are several steps you must complete.  For 
best results, these steps should be completed in this order: 
 

1. Uninstall the existing SolidNetwork License Server (if applicable) 
2. Install the SolidNetwork License Server 
3. Install SolidWorks client installations 

 
If the server has an existing SolidNetwork License Server installed and running, then you must launch 
this tool and press “Stop” to stop the licensing service.  You can then uninstall this via Control Panel > 
Programs and Features (Add/Remove Programs in WinXP). 



Page 4  SolidWorks New User Tips  

The SolidNetwork License Server software can be installed from the SolidWorks DVD by launching the 
regular SolidWorks Installation Manager, or by downloading just the license manager software from 
the SolidWorks Customer Portal.  For more information on using the Customer Portal, see the section 
of this document entitled Using the Customer Portal.   
 
The SolidNetwork License Server is typically installed on a server, but it could alternatively be installed 
on a SolidWorks client machine if desired.  If installing on a server, it is only necessary to install the 
license server software, not the entire SolidWorks application.   
 
After launching the standard SolidWorks Installation Manager, enter your SolidWorks Network license 
serial number.  When prompted for the installation type, choose “Server Products”, followed by 
selecting only “Install SolidNetwork License Server…”. 
Note that if you have specifically downloaded just the SolidNetwork License Manager then you may 
not need to choose this. 
 

 
 
Continue with the installation.  When prompted, enter your network serial number. 
If you have multiple network serial numbers, enter those at the next screen, with a comma separating 
each serial. 
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Once the installation completes, you can launch the SolidNetwork License Manager from the 
SolidWorks program group via the Start menu.  You will need to activate the license manager before it 
will become fully functional; for instructions on this, please see the section of this document entitled 
Activating the SolidNetwork License Server.   
 

Installing SolidWorks on Clients (SNL) 

 
* IMPORTANT - When attempting to install SolidWorks, you should be logged in as the Administrator 
on that computer. 
 
Before the installation begins, any anti-virus or anti-spyware should be completely disabled using the 
Services menu.  This can be accessed by going to Start-> Run, type “services.msc” (without 
quotations).  Once the Services window has opened select each instance of the anti-virus program and 
stop it. 

 
 
* IMPORTANT - If you are running Windows Vista or Windows 7, it is recommended to disable your 
User Account Controls as this can cause conflicts with your SolidWorks installation.  For steps to disable 
this option, browse to http://www.javelin-tech.com/blog/2011/01/uac/  
 
Once the anti-virus and User Account Controls have been completely disabled, and you are logged in as 
the system administrator, you can begin the SolidWorks installation.  When prompted to enter your 
SolidWorks serial number, enter the 16 or 24 digit serial number.  If you have a 16 digit serial, leave the 
last 2 boxes empty when entering the serial number (there is room for 24 digits). 
 
Note:  If you have purchased multiple SolidWorks products (such as Simulation, Motion, etc), then you 
must click the blue link “Click here to enter additional serial numbers” to enter the serial number for 

http://www.javelin-tech.com/blog/2011/01/uac/
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each separate product that you have purchased and wish to install, even if the serial numbers are the 
same for each product. 
 

 
 
Continue with the installation.  For further information, click the blue link “here in the documentation” 
or click the “Help” button within the SolidWorks Installation Manager. 
For information on installing multiple releases of SolidWorks in unique directories, see the section of 
this document entitled Installing to a Unique Directory. 
 

Installing SolidWorks with Unique Install Directories 

It is possible to install multiple releases of SolidWorks (i.e. SW2011, SW2010, etc.) on the same 
computer.  If you wish to install more than one version of SolidWorks (or may in the future), it is 
essential to have the different versions of SolidWorks, as well as the Toolbox databases, installed in 
unique locations.  This will ensure that having multiple installs is successful and all functionality is 
working as intended because each version of SolidWorks has a completely unique set of files to use. 
 
When installing SolidWorks, you will be prompted for an installation directory; the default is typically 
“C:\Program Files\SolidWorks Corp”.  Simply edit this location by adding the release year to the folder 
name to make it “C:\Program Files\SolidWorks Corp 2010” (for SW2010). 
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Similarly, when choosing a location for the Toolbox, you can add the version to the install folder.  This 
can be done regardless of whether you are creating a local database (for a single user) or a network 
based Toolbox (for multiple users). 
 

 
 
Making these small changes when first installing SolidWorks can prevent many issues later on if 
multiple versions of the software are installed at the same time. 
 

Updating Existing SolidWorks Installations – Major Release 

When updating your SolidWorks installation from one major release to another (ie. From 2010 to 
2011), if you don’t intend to have multiple releases of SolidWorks installed on the same machine then 
it is typically recommended to uninstall your previous version of SolidWorks before installing the new 
version.   Alternatively, you could upgrade the existing installation to the new version. 
 

Updating Existing SolidWorks Installations – Minor Release (Service Packs) 

To update the service pack of the SolidWorks installation, you can download the installation fileset 
from the SolidWorks Customer Portal.   
 
When attempting to update the SolidWorks service pack, you should be logged in as the Administrator 
on that computer. 
 



Page 8  SolidWorks New User Tips  

Before the modification of the SolidWorks installation begins, any anti-virus or anti-spyware should be 
completely disabled using the Services menu.  This can be accessed by going to Start-> Run, type 
“services.msc” (without quotations).  Once the Services window has opened select each instance of the 
anti-virus program and stop it. 
 

 
 
After downloading the necessary files from the SolidWorks Customer Portal, you can launch the 
Installation Manager, continuing through the steps to modify the individual installation.  Once the 
service pack update has completed, restart the computer and proceed.  
 

Updating Home Use License (HUL) Installations 

Companies that own a network seat of SolidWorks can apply for a Home Use License (HUL).  HUL seats 
for SolidWorks are typically installed and activated in the same way as a standalone seat of SolidWorks.  
A HUL serial number does typically not allow direct downloading of files from the SolidWorks Customer 
Portal (for installation/upgrade purposes).  To get around this then, you can use the “Download Only” 
option to download without being prompted for the serial number.  If you are prompted for a serial 
number during the download phase, then you should enter your network serial number.  Once you 
have downloaded the files and wish to start the install/update, you can again use the HUL serial 
number.   
 

Upgrading SolidWorks package from one package to another 

If you have just purchased an upgrade, i.e. SolidWorks to SolidWorks Premium, to apply this to existing 
installations is very easy and straight forward by following these steps. 
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1. Start by ensuring SW is not running. 
2. Ensure you disable your anti-virus service; see page 2 for instructions how this is done. 
3. Go to START > Control Panel > Programs > Programs & Features (Add/Remove Programs in XP) 

> locate the SolidWorks item, right-click on it, select Change. 
4. The SolidWorks Installation Manager will appear. 
5. Pick the Modify option and select Next: 

 
 

6. The screen showing your serial number(s) will appear, leave this as-is and select Next. 
7. SolidWorks will then connect online to the activation server and will “see” your new product 

package entitlement and will automatically select it. 
8. Click Next to acknowledge the new product and have the additional components installed.  

Once completed, reboot your machine. 
9. You are now ready to begin using your new SolidWorks package upgrade. 

 
NOTE: if the machine does not have Internet access, then it will NOT automatically “see” the 
upgrade and you’ll have to manually select it, and then proceed with step 8: 
 

 
 

 

  



Page 10  SolidWorks New User Tips  

SolidWorks Activation 

Activating a SolidWorks Standalone License 

Each standalone SolidWorks product (doesn’t use network licensing) must be activated to make use of 
it.  Each seat will typically have a maximum of 2 activations.  These 2 activations are typically meant for 
a machine at the office and at home, or a desktop and a laptop; to make use of both activations at the 
same time would violate the license agreement.  Using the Activation Wizard, you can contact the 
SolidWorks activation server directly or via email to activate or transfer an existing activation. 
When launching SolidWorks for the first time, the Activation Wizard will typically launch automatically.  
If it does not launch, go the Help-> Activate Licenses.  Simply choose which product to activate, and 
the activation method – if the computer has an active internet connect then you would typically 
choose “Automatically over the internet”. 
 

  
 
You can then follow the steps to complete the activation. 
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Activating a SolidNetwork License Server 

Beginning with SW2010, the SolidNetwork License Server is activation based.  After installing the 
license server software you must activate the product to identify that specific computer as the 
licensing server.  There can only be a single licensing server activated for any SolidNetwork serial 
number. 
 
* IMPORTANT – The activation process should always be done on the physical server.  Using a Remote 
Desktop application can cause the computer ID to change which will cause the activation to fail. 
 
To activate the server, launch the SolidNetwork License Manager.  If you are not immediately 
prompted to activate, then, from the Server Administration tab choose Modify-> Activate/Reactivate 
a software license.  Follow the steps to complete the activation.  If the licensing server has internet 
access then you would typically choose to activate “Automatically over the internet”.   
If you have entered multiple network serial numbers, use “Select All” to transfer all of the product 
licenses. 
 

Transferring a SolidWorks Standalone License 

To transfer a license from one computer to another (i.e. if you are uninstalling SolidWorks) you must 
first transfer the license from the existing computer (Help-> Transfer Licenses), followed by activating 
SolidWorks on the new computer (Help-> Activate Licenses).  Simply follow the steps to complete both 
of these steps and the SolidWorks license will be transferred to the new machine. 
 

Transferring a SolidNetwork License Server 

For each network serial number, there can only be a single computer activated as the licensing server.  
If you wish to change this licensing server, you must first transfer the activation away from the existing 
licensing server. 
 
To transfer the server, launch the SolidNetwork License Manager.  From the Server Administration tab 
choose Modify-> Transfer a software license.  Follow the steps to complete the transfer.  If the 
licensing server has internet access then you would typically choose to transfer “Automatically over 
the internet”.   
 
If you have entered multiple network serial numbers, use “Select All” to transfer all of the product 
licenses. 
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The Toolbox Database 

Custom Database Location 

The SolidWorks Toolbox can be located on a local machine for access by a single SolidWorks client, or it 
can be located on a network location for access by multiple SolidWorks clients.  The default location for 
the Toolbox is “C:\SolidWorks Data”.  
 
If you wish to create a network Toolbox, you can simply copy this entire SolidWorks Data folder to a 
network location.  After having moved the Toolbox, it is important to update SolidWorks to reference 
the correct Toolbox location.  You can do this by going to Tools-> Options-> Hole Wizard/Toolbox, 
then clicking the button to point to the correct Toolbox location. 
 

 
 

Toolbox Permissions and File Attributes 

To ensure proper functionality of the Toolbox, it is important to ensure that the proper permissions 
and file attributes are assigned, especially for network based Toolboxes where there may be multiple 
users. 
For permissions, each user that requires access to the Toolbox should have Full Control to the entire 
SolidWorks Data folder (and all sub-folders and files).  
It is also important to ensure that the file “SWBrowser.mdb” (located within “\SolidWorks 
Data\lang\English”) does not have a Read-Only Windows attribute.  Typically, the entire “\SolidWorks 
Data\Browser” folder is set to have a Read-Only Windows attribute; this is acceptable. 
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Using the SolidWorks Customer Portal 
 
If you are enrolled in the SolidWorks Subscription Service program, then you will be able to use the 
SolidWorks Customer Portal with full access.  The Customer Portal provides access to software service 
pack updates, a Knowledge Base for troubleshooting, user forums, etc. 
The SolidWorks Customer Portal can be accessed via http://customerportal.solidworks.com.  At this 
page, you can login using your account email and password.   
 

Creating an Account 

If you haven’t yet created a Customer Portal account, you can create a new one using the link “Click 
here to create an account” on the right side of the page.  Note that you will need your SolidWorks 
serial number to create an account.  Simply follow the steps, including the creation of a login (your 
email) and password. 
 

 
 

Unlocking the Customer Portal 

After you have created your account and logged in, there may be a “lock” symbol next to some of the 
items on the page.  This indicates that your Customer Portal account has not been completely 
registered.  To register the account, click Register My Products from the Customer Portal homepage.   

http://customerportal.solidworks.com/
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You can then follow the steps to register the account, ensuring to select the latest version of 
SolidWorks (i.e. 2011) as the product that you are registering.  After you have completed the 
registration procedure, the account should be fully functional after logging back in. 
 

Downloading from the Customer Portal 

The Customer Portal can be used to download service pack updates, individual smaller installs (such as 
the SNL License Manager), and the entire SolidWorks installation fileset which can be used in place of a 
DVD or to burn a new DVD. 
 
There are several options when downloading using the Installation Manager from the Customer Portal.  
Typically, the best option would be to choose the “Download Only” option as these files that are 
downloaded are the complete SolidWorks files that can be used to a) burn an install DVD, b) install 
SolidWorks, or c) upgrade the SolidWorks service pack.  This option is particularly useful when multiple 
machines need to upgrade or be installed, due to the fact that after being downloaded this full fileset 
can be transferred to any computer that requires it.  Alternatively, you can choose “Individual 
Installation” to download and install for this specific computer only.  Finally, if you wish to download 
just server products (such as the SolidNetwork License Manager) you can choose the option for “Server 
Products”. 
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To download these files, login to the Customer Portal and click “Downloads and Updates” followed by 
choosing the version of SolidWorks that you wish to download.  The first file that will be downloaded is 
the Installation Manager; upon running this file the Installation Manager will launch and you will be 
able to choose your download options. 
 

 
 
After the files have been downloaded (the default location is ~My Documents\SolidWorks Downloads\) 
if you need to launch the SolidWorks Installation Manager, you can do this by launching the 
“setup.exe” file from within the root download directory. 
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Saving Document Templates to Custom Locations 
 
It is often necessary to create your own customized document templates and drawing sheet formats.  
The default SolidWorks save locations for these files is within a directory that should be deleted if 
SolidWorks is fully uninstalled properly.  If you have not created a backup of your templates, they will 
also be deleted.  It is because of this that it is typically advisable to create a unique folder location 
(outside of the SolidWorks install directory) for these files to be saved in to prevent future data loss. 
 
When saving a document template (go to File-> Save As), upon choosing the template file type from 
the drop down list, the save location automatically changes to the SW default template location.  This 
is typically “C:\Documents and Settings\All Users\Application Data\SolidWorks\SolidWorks 
2011\templates”.  You can then change the save location to a custom location, such as “C:\SolidWorks 
2011 Templates”. 
After saving the template, you must modify the SolidWorks options to actually reference the new 
template location.  Go to Tools -> Options-> File Locations, choosing Document Templates from the 
drop down list.  You can then click Add and browse to your new template location. 
 

 
 
After adding the new document template file location, click OK to accept this change.  If prompted to 
add this location as a search location, you can typically click Yes.   
 

To use this new template, go to File-> New, and the new 
template location will be listed as a separate tab within the New 
SolidWorks Document dialogue. 
 
 
 

A similar procedure can also be followed to save a drawing sheet format and then update the Sheet 
Format file locations within SolidWorks. 
 
It’s also possible to save document templates and drawing sheet formats to network locations.  This 
can then allow multiple computers to access this network location, thereby ensuring that all 
SolidWorks users are utilizing the exact same templates. 
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Using the Copy Settings Wizard 
 
SolidWorks makes extensive use of the Windows registry, including saving individual user 
customizations such as file locations, toolbar settings, hotkeys, etc.  Unfortunately, in some cases files 
within the registry can become corrupted, which requires the deletion of entire registry folders.  This 
will result in all of a user’s customizations being lost, which can be time consuming and frustrating to 
recreate.  It is because of this that is highly recommended to backup your SolidWorks settings using the 
Copy Settings Wizard as soon as you have created your customized settings. 
 

Saving your SolidWorks Settings 

To use the Copy Settings Wizard, with SolidWorks closed go to Start-> All Programs-> SolidWorks-> 
SolidWorks 2011-> SolidWorks Tools-> Copy Settings Wizard.   
 

 
 
After launching the program, choose the option to Save your settings.  After selecting which options to 
save, click Finish.  This will create an .sldreg file which contains all the settings information. 
 

Restoring your SolidWorks Settings 

If you need to reload your SolidWorks settings from the file, simply double-clicking the .sldreg file will 
launch the Copy Settings Wizard.  Follow the steps to Restore your settings – typically restoring only 
for the current user. 
Note that the Copy Settings Wizard is also commonly used to propagate identical SolidWorks settings 
to multiple machines.  The .sldreg settings file can be run on other machines to load the SolidWorks 
settings. 
 
 
 


